Перестановка У вас есть массив чисел длиною "N". Нужно найти умноженную вариацию массива. Умноженный вариант массива это такой массив, где nums[i] это произведение всех чисел кроме nums[i]. Например, для массива [1,2,3,4] ответ будет равен [24,12,8,6].

Входные данные:

(1 ≤ n ≤ 10000), где каждый элемент в массиве в промежутке (-10000 ≤ a[i] ≤ 10000)

Выходные данные:

Нужно найти умноженную вариацию массива.

Stefan123005 Stefan123005    2   04.12.2020 19:19    9

Ответы
cot579 cot579  03.01.2021 19:24

python

arr = [int(i) for i in input('Введите числа через пробел: ').split()]

new_arr = []

for forbidden_index in range(len(arr)):

 first = True

 for index in range(len(arr)):

   if index != forbidden_index:

     if first:

       new_arr.append(arr[index])

       first = False

     else:

       new_arr[forbidden_index] *= arr[index]

print(new_arr)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика