tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Паскаль! задано слово длины
Паскаль! задано слово длины 3n(n- натуральное число). удалить в нем последнюю треть слова, а оставшиеся две трети перевернуть.
AnutaBelova1524
1 28.08.2019 07:50
3
Ответы
bubliknazar2003
06.10.2020 00:12
var s,s1:string; n,i:integer;
begin
writeln('Введите слово длиной 3n:');
readln(s);
n:=length(s) div 3;
delete(s,2*n+1,n);
s1:='';
for i:=1 to 2*n do s1:=s[i]+s1;
writeln(s1);
end.
Пример:
Введите слово длиной 3n:
programma
argorp
ПОКАЗАТЬ ОТВЕТЫ
sleshkevich
06.10.2020 00:12
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('Введите слово с числом символов, кратным 3:');
s:=s[:s.Length div 3 * 2+1].Inverse;
s.Println
end.
Пример
Введите слово с числом символов, кратным 3: 1234567890abcde
0987654321
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
булати
26.02.2020 20:57
Принтер,монитор, клавиатура как будет одним словом...
Ferzpi
26.02.2020 20:57
Дан одномерный массив. а) найдите сумму четных элементов массива б)среднее арифметическое элементов массива, которые оканчиваются на 5 в) элемент равный x(вводится с клавиатуры)...
glo2
18.04.2021 22:31
Написать программы по Pythony. 1.Найти сумму четных цифр и произведение нечетных цифр заданного целого числа х 2.Найти количество четных цифр и нечетных цифр заданного целого числа...
SkyForce144
18.04.2021 22:31
Напишите программу питона, которая определяет гиперпростое это число или нет ( без true/false и тд если можно)...
1Данил111
18.04.2021 22:34
Які ви знаете різновиди цілих типів...
Мне0нужна0помощь
18.04.2021 22:41
Вопрос 1 Напишите программу на языке Python, которая получает с клавиатуры натуральное число и определяет количество цифр в этом числе, Введите ответ в произвольной форме: ,...
EveChan
23.10.2020 12:15
Текстові процесори та видавничі системи використовують спеціально розроблені формати файлів, що містять не тільки текст, а й відомості про те як він має бути оформлений. Ці додаткові...
MartinaStoessel2
23.10.2020 12:14
2. «Разминка». Разгадай анаграммы:1. ИВАНИПЕЛАРОН2. БАЗАРТОКАР3. СОВАНИТEРИТЕ4. ЦЕОНАККакие слова получились?Что объединяет все эти процессы?В какой последовательности они должны...
софья20054
24.06.2021 16:50
Проект на тему Вавилонська рибка...
антонl
24.06.2021 16:15
написать программу на С++, желательно более простыми командами,заранее . На вход программе подаётся: в первой строке — число N (5 N 109 ). В каждой из последующих N строк — по одному...
Популярные вопросы
Втреугольнике mhk угол k равен 120 градусов, а сторона mh=30мм. из точки h в треугольнике...
3
Спиши расставь знаки препинания составь схему первого и второго предложения с...
3
Построение областей на ,,мне нужно ...
3
Настоящая семья (5-6 предложений) !...
1
Хелп ! make the following sentences interrogative and negative 1. the children...
2
Чем подростковый возраст отличается от взрослого...
2
5-10 предложений где описывается природа из произведения детство толстова. ! завтра...
3
Запиши пары слов в таком порядке родственные слова формы одного и того же слова...
3
Откуда учёные берут источники?...
2
Решить не вру , 99 на соревнованиях по горным лыжам волк-победитель показал следующие...
2
begin
writeln('Введите слово длиной 3n:');
readln(s);
n:=length(s) div 3;
delete(s,2*n+1,n);
s1:='';
for i:=1 to 2*n do s1:=s[i]+s1;
writeln(s1);
end.
Пример:
Введите слово длиной 3n:
programma
argorp
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('Введите слово с числом символов, кратным 3:');
s:=s[:s.Length div 3 * 2+1].Inverse;
s.Println
end.
Пример
Введите слово с числом символов, кратным 3: 1234567890abcde
0987654321