Вопрос 1 Напишите программу на языке Python, которая получает
с клавиатуры натуральное число и определяет
количество цифр в этом числе,
Введите ответ в произвольной форме:
,

Мне0нужна0помощь Мне0нужна0помощь    1   18.04.2021 22:41    1

Ответы
MarkZz MarkZz  18.04.2021 22:50

Відповідь:

N=int(input())

c=0

while N>0:

   N=N//10

   c=c+1

print(c)

Пояснення:

ПОКАЗАТЬ ОТВЕТЫ
ДАШУНЯ1311 ДАШУНЯ1311  18.04.2021 22:50

i=int(input())

if i<0:

   print(len(str(i))-1)

else:

   print(len(str(i)))

Объяснение:

проверяем положительное ли число, если нет, то из длины символов вычитаем 1 (т.к. у нас "-" считается за символ), иначе выводим просто длину

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика