Паскаль! составить программу: 1)вводим любое четырехзначное число. в результате выполнения программы на экране такая запись: в числе - тысяч - сотен -десятков - единиц в скобках < > указаны переменные, сами скобки обозначают - в этом месте. 2)ввести с клавиатуры трехзначное число. определить сумму его цифр (переменная sum) и вывести эти цифры в обратном порядке. в результате выполнения программы на экране такая запись: в числе - сотен -десятков -единиц в скобках < > указаны переменные, сами скобки обозначают - в этом месте

жансая87 жансая87    2   27.07.2019 06:50    6

Ответы
Kajdit Kajdit  25.09.2020 09:47
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  var n:=ReadInteger('Введите четырехзначное число');
  Writeln('В числе');
  Writeln(n div 1000,' - тысяч');
  Writeln((n div 100) mod 10,' - сотен');
  Writeln((n mod 100) div 10,' - десятков');
  Writeln(n mod 10,' - единиц')
end.

Тестовое решение:
Введите четырехзначное число 4072
В числе
4 - тысяч
0 - сотен
7 - десятков
2 - единиц

// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  var n:=ReadInteger('Введите трехзначное число');
  var s:=n div 100;
  var d:=(n div 10) mod 10;
  var e:=n mod 10;
  Writeln('Sum=',s+d+e);
  Writeln(e,d,s);
  Writeln('В числе');
  Writeln(e,' - сотен');
  Writeln(d,' - десятков');
  Writeln(s,' - единиц')
end.

Тестовое решение:
Введите трехзначное число 492
Sum=15
294
В числе
2 - сотен
9 - десятков
4 - единиц
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика