Паскаль пусть вводится последовательность вещественных чисел, оканчивающаяся нулем и состоящая более чем из одного ненулевого элемента. определите наибольшее число последовательности.

Alinahe2001 Alinahe2001    3   27.06.2019 14:50    4

Ответы
daniltyrov719 daniltyrov719  21.07.2020 23:58
Попробуй так:

uses Crt;
var a, Max: real;
    i: integer;
begin
ClrScr;
i:=0;
Repeat
  i:=i+1;
  Write ('a',i,'='); ReadLn (a);
  if a<>0 then
      begin
        if a>Max then Max:=a;
      end;
  until a=0;
WriteLn;
WriteLn(' Max = ', Max:6:4);
ReadLn;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика