tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Паскаль: найти сумму цифр
Паскаль: найти сумму цифр в числе при оператора repeat.
zulyakhalilova
1 03.09.2019 00:10
4
Ответы
23774947hhbhut
06.10.2020 13:29
Var
A:longint;
S:integer;
Begin
Write('Введите целое число: ');Read(A);
S:=0;
A:=Abs(A);
Repeat
S:=S+A mod 10;
A:=A div 10;
Until A = 0;
Write('Сумма цифр числа: ',S);
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
thebrofee
01.12.2020 10:58
Запиши верный ответ.(Впиши соответствующую латинскую букву или цифру)C V C=...
gulitenko
01.12.2020 10:51
ХАЛЯВНЫЕ . ТЫ ДОЛЖЕН ПОДПИСАТЬСЯ НА ЮТУБ КАНАЛ И ПОСТАВИТЬ ЛАЙК К ОДНОМУ ВИДЕО Я ПРОВЕРЮ, КАНАЛ НАЗЫВАЕТСЯ СПОРТИКИ (ЗАГЛАВНЫМИ БУКВАМИ), ЕСЛИ НЕ СДЕЛАЛ ВЫШЕ УКАЗАННЫХ УСЛОВИЙ ТО БАН,...
nasti0902003
01.12.2020 10:49
Введите число от 1 до 100 проверьте это результат выведите в файл output.txtpascal...
SophiakoSheleva5666
10.12.2020 05:08
Ивт сор . Мщображение на экране монитора образуются из отдельных точек называются А) точек.В)пиксель.Б)кубГ)эскиз милые дайте только верный ответ за ранее...
reor1878p02hjw
10.12.2020 05:09
С ПРАКТИЧЕСКОЙ ПО ИНФОРМАТИКЕ Задание 1 Запустите Microsoft Word 2010. Сверните ленту с использованием кнопки в линии названий вкладок. Разверните ленту двойным щелчком по названию...
ирина1834
22.08.2019 15:10
Министр финансов дурляндии выпустил в обращение только монеты достоинством в 7 и 11 дуриков. покупатель должен заплатить продавцу ровно 5 дуриков. сумеют ли они рассчитаться, если...
00SERGEI2003
22.11.2020 12:57
Исправить ошибки: program pr4-2 ; const m=3; n=4; var a : array [l .. m, 1 .. n] of integer; (* описание матрицы *) b : array [1 .. n] of integer; (* описание вектора *) c : array...
mariapodgornova
17.05.2020 15:14
Дана матрица В размером 5х7 . Составить программу формирования вектора , элементы которого равны сумме элементов столбцов матрицы В...
ksuhamalinovskaj
17.05.2020 15:16
1. Набрать программу и проверить ее работу для Х: -2, 1, 5, 6. 2. Эту же задачу решить для условия: 1) Х 0 или Х=5 или Х=8 2) Х =0 и Х 5 и Х 6 Проверить работу программы для Х: -2,...
Glowly
04.11.2020 22:52
Написать программу, которая находит сумму четных чисел до ввода цифры 0....
Популярные вопросы
с сочинением. Сочинение на тему: Для чего нам нужны вводные слова? .Примеры вводных...
3
Выпиши из предложений глаголы, запиши их в неопределённой форме и в форме 3-го лица...
2
Стороны угла A касаются окружности с центром O радиуса R. Определи расстояние OA,...
3
с лабораторной работой) ❤️✨...
1
2) Определите дефект массы и энергию связи ядра трития 31Н (mя = 3,016049 а. е....
2
Визначте складне речення з рiзними видами звьязку та вкажiть це в дужках.1)Я сподiваюсь,що...
3
Обществознание, Человек в экономических отношениях, 7 класс...
1
Правильные ответы на грибной диктант 1. … Царство Грибы 2. … не имеют хлорофилл,...
1
Синтаксический разборпредложения А) Длин..ая плотина обсажен..ая с..р..бристыми...
3
Назвіть дієслова у фразеологізмах. У якій формі вони вжиті? Замініть фразеологізми...
3
A:longint;
S:integer;
Begin
Write('Введите целое число: ');Read(A);
S:=0;
A:=Abs(A);
Repeat
S:=S+A mod 10;
A:=A div 10;
Until A = 0;
Write('Сумма цифр числа: ',S);
End.