Написать программу, которая находит сумму четных чисел до ввода цифры 0.

Glowly Glowly    1   04.11.2020 22:52    4

Ответы
Zhenya2099 Zhenya2099  04.12.2020 22:53

#include <iostream>

#include <vector>

using namespace std;

void solve(){

   int sum = 0;

   while(true){

       int x;

       cin >> x;

       if(x == 0)

           break;

       sum += (x % 2 == 0) * x;

   }

   cout << sum;

}

signed main(){

   solve();

}

ПОКАЗАТЬ ОТВЕТЫ
arsenmalhasan20 arsenmalhasan20  04.12.2020 22:53

program z1;

var a,s:integer;

begin

a:=-1;

s:=0;

while a <> 0 do

begin

write('a = ');

readln(a);

if a mod 2 = 0 then s:=s+a

end;

write('s = ', s)

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика