Паскаль написать программу,которая будет открывать txt файл,искать нужный текст и удалять его.после чего сохранит изменения. нужно использовать цикл,т.к.поиск будет осуществляться много раз! txt файл большой,с большим количеством перехода на новую строку.

Phelper Phelper    1   09.06.2019 19:30    4

Ответы
leron9999 leron9999  08.07.2020 13:03
Лучше писать результат не в тот же файл, а в другой: при составлении регулярных выражений без достаточного опыта можно легко ошибиться.

uses
  System.Text.RegularExpressions;

const
  CRLF = #13#10;

var
  s, sbig: string;
  fin, fout: Text;

begin
  Assign(fin, 'MyIn.txt');
  Reset(fin);
  sbig := '';
  while not Eof(fin) do
  begin
    Readln(fin, s);
    sbig := sbig + s + CRLF
  end;
  Close(fin);
  {пример - уладить подстроки, начиная с "http:" и до первого пробела,
  причем внутри подстроки может встретиться переход на новую строчку.
  Используется шаблон '\bhttp:\S+' - подробности: регулярные выражения}
  sbig:=RegEx.Replace(sbig, '\bhttp:\S+', '', RegexOptions.Multiline);
  Assign(fout, 'MyOut.txt');
  Rewrite(fout);
  Write(fout, sbig);
  Close(fout);
  Writeln('Конец работы');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика