Составить программу на языке Паскаль для решения следующей задачи: Дан одномерный массив. В массиве хранятся оценки по информатике учеников 9 класса. Заполнить массив случайными числами, лежащими в диапазоне от 2 до 5 включительно. Вычислите среднюю оценку в классе по информатике. Входные данные для размерности массива задайте самостоятельно.

На проверку нужно прислать текст кода программы, результат работы кода в виде скриншота окна программы с отображением кода и полученного результата. Программная реализация обязательна!

vikaprovotorova vikaprovotorova    2   26.02.2022 17:25    123

Ответы
Дианп11 Дианп11  26.02.2022 17:30

Программа:

Pascal:

var

 arr: array of integer;

 n, i, sum: integer;

begin

 write('Количество учеников: '); readln(n);

 SetLength(arr, n);

 

 for i := 0 to n - 1 do begin

   arr[i] := random(2, 5);

   sum += arr[i];

 end;

 writeln('Оценки учеников в классе: ', arr);

 writeln('Средняя оценка: ', sum/n);

end.

Для начала выделяем память массиву целых чисел, после - регистрируем переменные, которые будем использовать далее. Запрашиваем кол-во учеников (это и будет размерностью массива), устанавливаем длину массива - введённое число n. Циклом проходима по элементам массива, устанавливаем рандомное значение от 2 до 5 и суммируем элементы. В конце выводим сам массив и высчитываем среднюю оценку как среднее арифметическое чисел.


Составить программу на языке Паскаль для решения следующей задачи: Дан одномерный массив. В массиве
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика