Паскаль: написать программу для определения в двумерном массиве целых чисел d[6,6] максимальный элемент под главной диагональю. оформить ввод/вывод массива.

askerovaa1 askerovaa1    1   14.07.2019 18:20    3

Ответы
diasjabarrrrrrrr diasjabarrrrrrrr  03.10.2020 04:13
Var a:array [1..100, 1..100] of integer; 
i,j,max:longint; 
begin 
for i:=1 to 4 do 
for j:=1 to 4 do read(a[i,j]); 
max:=a[2,1]; 
for i:=1 to 6 do 
for j:=1 to 6 do 
if (a[i,j]>max) and (i>j) then max:=a[i,j]; 
for i:=1 to 6 do begin 
for j:=1 to 6 do write(a[i,j],' '); 
writeln; 
end; 
writeln('Максимальный элемент под главной диагональю - ',max); 
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика