tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Фрагмент программы на паскале:
Фрагмент программы на паскале: readln(a); b: =30; a=-a-3*b; if a
zwitterlord2
1 23.06.2019 05:00
2
Ответы
khmelyuko
19.07.2020 07:11
Код программы
var
a: integer;
function c(a: integer): integer;
var
b: integer;
begin
b := 30;
a := -a - 3 * b;
if a < b then
c := b + 45
else
c := b - 50;
end;
begin
for a := 1000 downto -1000 do
if c(a) = -20 then begin
writeln('a=', a, ' c(a)=', c(a));
break;
end;
end.
Вывод
a=-120 c(a)=-20
Аналитическое решение.
Видно что c:=b - 50 = 30 - 50 = -20 при a>=b
-a-3*b>=b
-a-3*30>=30
-a-90>=30
-a>=120
a<=-120
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
abdullaevs04
06.06.2019 20:10
Составь действия алгоритма по порядку и запиши его в трех формах: 1.посолила картофель. 2.бросила картофель в кипяток. 3.зажгла газовую плиту. 4.очистила картофель. 5.купила в магазине...
mikerinavera
27.07.2019 08:30
Имеется исполнитель кузнечик, который живет на числовой оси. система команд кузнечика: вперед n – кузнечик прыгает вперед на n единиц назад m – кузнечик прыгает назад на m единиц переменные...
aresu
27.07.2019 08:30
Предприниматель получает кредит на 40 тысяч рублей на 4 года под 25% годовых.определить какую сумму он выплатит за это время.какой взнос ему придётся выплачивать ежегодно...
katpetrompet4345
27.07.2019 08:20
Создайте и распечатайте в строчку одномерный массив, длиной n, следующим образом: а(1)=14, а(2)=15, а(3)=16, а(4)=-17, а(5)=-18, а(6)=-19, а(7)=20, а(8)=21, а(9)=22, ?...
romapotseluiko
29.07.2019 23:00
Написать программу, которая запрашивает ввод вещественного числа в переменную а, делит это число на 3 и прибавляет в переменную а. выводит результат на экран....
andrejpuzanov90
29.07.2019 23:00
Нарисовать и прямоугольный и синий и учебный...
vladasic
29.07.2019 23:00
Прочти описание команд,которые исполняет продовец когда взвкшивает товар на чашечных весах с гирями...
29Vladislava13
29.07.2019 23:00
Сколько мбайт информации содержится в статье из 64 страницы,если на каждой странице 80 строк а в строке 32 символа.при кодировании на каждый символ выделено 8 бит...
главный8
12.09.2019 06:10
Решить в pascal даны три слова a1,a2,a3 и их перевод p1,p2,p3. напечатать перевод заданного слова a4(a4=a1 или a2 или a3)....
Школьниқ
12.09.2019 06:10
Выберите неверное утверждение: в компьютерном классе а)прикасаться к экрану монитора б)работать мокрыми руками в)есть мороженое и пить соки г)проветривать помещение...
Популярные вопросы
4. Упростите выражение и найдите его значение 10х – 4х + х – 6х + 5 , при х Соч...
3
Задания суммативного оценивания за 2 четверть 8 класс ЧтениеПрочитайте текст и выполните...
3
ОЧЕНЬ-ОЧЕНЬ плоскостной 1 эпюр с 3 точек x y z A 60 60 10 B 45 15 55 C 0 5 25 D...
2
Потрібно зробити дуже терміново !...
2
Строчно нужно сделать химию...
3
(+0,3)+(+0,7) (-0,7) + (+0,6)(+0,03) + (-0,05)(-1,9)+(-0,6)(+2,8) + (-2,8)(-0,5)...
1
Найти ответы на вопросы и записать в тетрадь: Что в переводе с французского означает...
2
Раскройте скобки и приведите подобные слагаемые номер 743...
3
Этот история Казахстана СОЧ...
2
Укажите составные части каркаса юрты...
2
var
a: integer;
function c(a: integer): integer;
var
b: integer;
begin
b := 30;
a := -a - 3 * b;
if a < b then
c := b + 45
else
c := b - 50;
end;
begin
for a := 1000 downto -1000 do
if c(a) = -20 then begin
writeln('a=', a, ' c(a)=', c(a));
break;
end;
end.
Вывод
a=-120 c(a)=-20
Аналитическое решение.
Видно что c:=b - 50 = 30 - 50 = -20 при a>=b
-a-3*b>=b
-a-3*30>=30
-a-90>=30
-a>=120
a<=-120