Паскаль. много . дано целое трехначное число x.составьте программу вычисления суммы и произведения цифр трехзначного числа x. знасение x ввести с клавиатуры. тема с div и mod.

natalichexova natalichexova    2   17.09.2019 17:01    6

Ответы
Inna14888 Inna14888  07.10.2020 22:15
//Pascal
//Для натуральных чисел
var a, s, p:integer;

begin
  write('Введите число = ');
  readln(a);
  s := 0;
  p := 1;
  while (a<>0) do
  begin
    p := p * (a mod 10);
    s := s + (a mod 10);
    a := a div 10;
  end;
 writeln( 'Сумма цифр числа = ', s);
 writeln( 'Произведение цифр числа = ', p);
end.

//Если число отрицательное
var
  s, p, a, b, c: integer;
  f: boolean;
begin
  write('Введите число = ');
  readln(a);
  if a < 0 then
    f := true;
  a := abs(a);
  b := a mod 10;
  a := a div 10;
  c := a mod 10;
  a := a div 10;
  if f = true then
  begin
    p := (-a) * b * c;
    s := -a + b + c;
  end
  else
  begin
    s := a + b + c;
    p := a * b * c;
  end;
  writeln('Сумма цифр числа = ', s);
  writeln('Произведение цифр числа = ', p);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика