Паскаль авс. дана строка символов. составьте программу которая подсчитывает, сколько в данной строке слов оканчивающихся на а. все слова разделяются 1 пробелом и только буквы.

Dedsec08 Dedsec08    2   15.06.2019 17:20    3

Ответы
vyyy73ozxnyb vyyy73ozxnyb  12.07.2020 19:24
Var
  s: string;
  i, n: integer;
  a: set of char;

begin
  Writeln('Введите строку текста');
  Readln(s);
  n := 0;
  a := ['А', 'а'];
  for i := 1 to Length(s) do
    if (s[i] = ' ') and (s[i - 1] in a) then n := n + 1;
  if (s[i - 1] in a) then n := n + 1;
  Writeln('Количество слов, оканчивающихся буквой "а", равно ', n)
end.

Тестовое решение:
Введите строку текста
А роза упала на лапу Азора
Количество слов, оканчивающихся буквой "а", равно 4
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика