Pascalabc.net текстовый файл input.txt содержит натуральные числа. написать программу, которая создает текстовый файл output.txt, содержащий все четные числа файла input.txt в порядке возрастания.

вероника1060 вероника1060    1   29.09.2019 14:30    7

Ответы
777SwimmeR777 777SwimmeR777  09.10.2020 02:59

Попробуй этот код

uses crt;

var f,g:text;

   a,max,min:integer;

begin

assign(f,'C:\in.txt');

assign(g,'C:\out.txt');

reset(f);

rewrite(g);

max:=0;

min:=0;

reset(f);

while not eof(f) do

     begin

     read(f,a);

     if a>max then max:=a;

     if a<min then min:=a;

     end;

writeln(g,'max ',max);

writeln(g,'min ',min);

close(f);

close(g);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика