PascalABC. Написать программу, в которой выполняются следующие действия:
1. с клавиатуры вводится имя 1-го человека;
2. с клавиатуры вводится вес 1-го человека;
3. с клавиатуры вводится имя 2-го человека;
4. с клавиатуры вводится вес 2-го человека;
5. программа выводит имя более тяжелого человека (при равенстве весов
выводится имя 2-го человека);
6. в том случае, когда вес какого-либо человека или обоих не находится в
пределах от 3 до 150 программа выводит только сообщение «ошибка».

kauymbek kauymbek    3   23.05.2020 20:19    5

Ответы
Евус1111 Евус1111  15.10.2020 07:18

var

a, b:String;

c, d:Integer;

begin

readln(a);

readln(c);

if (c < 3) or (c  > 150)

then begin

 writeln('Ошибка');

 exit;

 end;

readln(b);

readln(d);

if (d < 3) or (d  > 150)

then begin

 writeln('Ошибка');

 exit;

end;

if c > d then  

 writeln(a)

else  

writeln(b);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика