Pascal В списке участников международной конференции указывается их национальность и возраст. Список упорядочен по возрасту участников. Определить самого молодого и самого пожилого русского участника. Нужно написать программу.

3224527 3224527    3   06.06.2020 17:52    38

Ответы
hakimov676 hakimov676  15.10.2020 13:18

Держи ;)

Var year,s,y,o:integer; old,young,name,nation:string;

Begin

s:=0;

o:=0;

y:=200;

While (s=0) do

Begin

Write('Введите имя и фамилию участника. Если список окончен, напишите "конец": ');

Readln(name);

If (name='конец') then break;

Write('Введите национальность участника: ');

Readln(nation);

Write('Введите возраст участника: ');

Readln(year);

If (year > o) and (nation='русский') then

Begin

o:=year;

old:=name;

end;

If (year < y) and (nation='русский') then

Begin

y:=year;

young:=name;

end;

end;

Write('Самый молодой русский участник - ',young,', самый старый русский участник - ',old);

End.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика