Pascal, составить программу с задачей! Компьютер запрашивает радиус круга и сторону квадрата. Надо определить, равные ли у них площади (ответ должен иметь вид: «Площади равные»). Если площади не равные, то выводится площадь меньшей фигуры.

аsiyt09 аsiyt09    3   16.12.2020 22:24    38

Ответы
Masanet Masanet  15.01.2021 22:25

//s1 - площадь круга, s2 - площадь квадрата

//а - cторона квадрата, r - радиус круга

const pi = 3.14;

var s1,s2,a,r:real;

begin

 write('введите а: ');

 read(a);

 write('введите r: ');

 read(r);

 s1:=pi*sqr(r);

 s2:=sqr(a);

 if s1 = s2 then writeln('площади равные')

 else

   if s1 > s2 then writeln('площадь квадрата: ',s2)

   else

     if s2 > s1 then writeln('площадь круга: ',s1);

end.

ПОКАЗАТЬ ОТВЕТЫ
Kristina1605lps Kristina1605lps  15.01.2021 22:25

var a,r:real;

begin

 readln(r);

 readln(a);

 if (a*a)=(r*r*pi) then

   writeln('Площади равны')

 else

   if (a*a)>(r*r*pi) then

     writeln('Площадь круга меньше, она равна: ', r*r*pi)

   else

     writeln('Площадь квадрата меньше, она равна: ', a*a)

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика