tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Pascal, составить на вход даётся
Pascal, составить на вход даётся число, определить произведение цифр числа кратных 3, если таких нет вывести на экран "нет".
Goldman2017
3 21.09.2019 07:01
0
Ответы
burdyugova48
08.10.2020 06:34
//PascalABC.NET
//Версия 3.3, сборка 1634
begin
var n:=abs(ReadInteger);
var a:=n.ToString.Select(x->x.ToDigit).Where(t->t mod 3=0);
if a.Count=0 then write('нет') else write(a.Aggregate(Real(1),(x,y)->x*y));
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
sasuke97
28.07.2019 13:20
Дан массив, содержащий 2014 неотрицательных целых чисел, не превышающих 10 000.опишите на языке программирования паскаль алгоритм, позволяющий найти и вывести сумму всех со-держащихся...
Marat445372
02.12.2019 13:21
1. даны три числовых ряда под названиями: «сторона а», «сторона в», «сторона с». a. в столбце под именем «площадь треугольника» ввести формулу герона, используя мастера функций....
mishanyak19991
11.12.2021 09:35
ЗАДАЧА С++ Ви поклали гроші в банк під 10% у місяць. Скласти програму, яка б визначала яка сума буде знаходитись на Вашому рахунку через N місяців....
liubovbalan
11.12.2021 09:34
Перечислите инструменты для создания трехмерных фигур...
imam1707
11.12.2021 09:32
ВОПРОСЫ И ЗАДАНИЯ 1. Расскажите о возможностях MS Word, 2. Объясните процесс форматирования документов. 3. Какие типы форматирования представлены в MS Word? 4. Объясните,...
babka5
11.12.2021 09:26
почему реклама воспроизводиться со звуком ?если звук выключен, (некоторая реклама)(в приложениях и играх)...
Thorwald
05.10.2019 23:13
Записать в нормализованной форме число 120,34. указать мантиссу и порядок....
6lackk
05.10.2019 23:13
Егэ информатика: № 16. значение арифметического выражения 16^15 - 4^13 + 2^48 +15 записали в сс с основанием 4. сколько цифр 3 содержится в этой записи?...
bdnhm1
06.10.2019 01:10
Описание программы: написать программу,которая в одномерном массиве из 30 элементов заполненных вручную,оценками учеников по предмету,диапазон оценок от 2 до 5. входящие в...
napolskai24
29.12.2020 18:57
На рисунках даны следующие виды графов: А) неориентированный, Б) ориентированный В) взвешенный Г) граф – сеть Д) граф – дерево....
Популярные вопросы
(1-1/3-1/6-1/9)*18 вычислите у меня что-то вообще не выходит...
3
Восстанови цепочку вычислений : 3/5+2/5=? -4/7=? -3/7=? +5/9=? +8/9=? 3_2/7+3/7=?...
3
Будова слова садку, обліпили, бджоляній...
1
Треугольник frt задан координатами своих вершин: f(2; -2), r(2; 3), t(-2;...
3
Сравните дроби: 5/8 и 3/4; 4/9 и 3/8...
2
Запишите реакция полимеризации 2-х аминокислот и укажите на дипеетиде пептидную...
2
Что объединяло а.ф.адашева и а.м.курбсково...
1
Сергійко їхав велосипедом 3 год зі швидкістю 12 км/год. з якою швидкістю...
3
Найдите все причастия и сделайте морфологический разбор 159 7 класс...
3
Составить 5 утвердительных , 5 отрицательных и 5 вопросительный предложений...
3
//Версия 3.3, сборка 1634
begin
var n:=abs(ReadInteger);
var a:=n.ToString.Select(x->x.ToDigit).Where(t->t mod 3=0);
if a.Count=0 then write('нет') else write(a.Aggregate(Real(1),(x,y)->x*y));
end.