Описание программы: написать программу,которая в одномерном массиве из 30 элементов заполненных вручную,оценками учеников по предмету,диапазон оценок от 2 до 5. входящие в эту программу: 1. подсчитать средний класса. 2. подсчитать кол-во двоечников, трое шнеков,хорошистов, отличников. хорошист 3.75-4-75. 3. подсчитать долю успевающих(всех у кого не 2) в паскалях

bdnhm1 bdnhm1    3   06.10.2019 01:10    4

Ответы
2004by2013 2004by2013  09.10.2020 22:47

program n_1;

var a: array [1..30] of integer; n, m, k, l, i:integer; s: double;

begin

 n:=0; m:=0; n:=0; k:=0; l:=0;

 for i:=1 to 30 do begin

   read(a[i]);

   s:=s+a[i];

   if a[i]=2 then m:=m+1

   else if a[i]=3 then n:=n+1

   else if a[i]=4 then k:=k+1

   else if a[i]=5 then l:=l+1

 end;

 writeln('Средний класса: ', s/30);

 writeln('Количество двоечников: ', m);

 writeln('Количество троечников: ', n);

 writeln('Количество хорошистов: ', k);

 writeln('Количество отличников: ', l);

 writeln('Успеваемость класса: ', (30-m)/3*10, '%');

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика