tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Pascal цикл while последовательно
Pascal цикл while последовательно вводятся числа, найти их сумму. ввод остановить после ввода второго нуля.
izmaylova77
3 18.08.2019 00:10
5
Ответы
кулл4
05.10.2020 01:49
Var a,s,k:integer;
begin
writeln('Вводите числа:');
k:=0;
while k<2 do
begin
readln(a);
s:=s+a;
if a=0 then k:=k+1;
end;
writeln('s = ',s);
end.
Пример:
Вводите числа:4
9
5
0
1
3
2
0
s = 24
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Reginka24082007
05.09.2019 10:20
Перевести число из одной системы счисления в другую: из двоичной в десятичную: 11001 – ? 2) 11011 – ? 3) 11110 – ? 4) 100101 – ? 5) 101001 – ? 6) 111010 – ? 7) 1000111...
Клер11330
05.09.2019 10:20
Что такой графический файл примеры , я просто забыла...
lera08862
05.09.2019 10:20
Как перевести число 0,051363636 из миллиона в тысячу в программе ms excel,чтобы программа сама перевела?...
Аня3321
05.09.2019 10:20
Ввести с клавиатуры двузначное число.найдите сумму,разность,произведение и частность цифр...
lmarki2003
05.09.2019 10:20
Для хранения растрового изображения 128*128, объем памяти составляет 8кб. какого возможное количество цветов в политре?...
Настёна30072003
05.09.2019 10:30
Даны два числа x и y напишите программу в результате которой эти два числа поменяются значениями...
Ніка64
05.09.2019 10:30
Перевести свою дату рождение в двоичную систему сложит и перемножить попарно. ( 23.03.2003 )...
Poolll
05.09.2019 10:30
Скорость передачи данных через adsl-соединение равна 1024000 бит/с. сколько минут займет передача файла размером 600000 кбит через данное соединение...
Karina0980
05.09.2019 10:30
Все нужно делать через форумлу шенона,находя вероятность. 1)алфавит племени мульти состоит из 32 символов. члены племени используют в своей речи и письме только слова...
клим512
05.09.2019 10:30
Скаких действий можно сделать активной ячейку а установить указатель мыши на ячейку б дважды щелкнуть левой кнопкой мыши в щелкнуть левой кнопкой мыши г щелкнуть правой...
Популярные вопросы
Составить сочинение об осени, с метафорами, сравнениями и эпитетами....
1
Значение пословице бумажному фонарю медный колокол...
2
Сочинение на тему: моё путешествие в лондон...
1
Скорость лодки против течения реки 5 км в час собственная скорость...
3
Приглашаем всех с нами вместе поиграть! внутри этих слов спрятались...
2
Сочинение сказка небольшое на любую тему...
2
Как называются белки которые упорядочивают и ускоряют протекание...
2
Масса соли, которая образовалась при сливании растворов, содержащих...
3
Напишите ввиде таблицы ход войны -японской войны....
1
Pomogite u mena problema skoko budet 4*248...
3
begin
writeln('Вводите числа:');
k:=0;
while k<2 do
begin
readln(a);
s:=s+a;
if a=0 then k:=k+1;
end;
writeln('s = ',s);
end.
Пример:
Вводите числа:4
9
5
0
1
3
2
0
s = 24