Pascal abc. написать программу которая определяет знак зодиака при вводе даты рождения (с использованием case).

Алишер00001 Алишер00001    1   27.08.2019 00:10    5

Ответы
kyrmaeva200614 kyrmaeva200614  14.08.2020 20:49
Var n,d:integer;
begin
write('Введите месяц :');
readln(n);
write('Введите день :');
readln(d);
n:=n mod 12;

 case n mod 12 of
 1: if d<=20 then writeln('Козерок') else writeln('Водолей');
 2: if d<=21 then writeln('Водолей') else writeln('рыба');
 3: if d<=21 then writeln('рыба')   else writeln('овен');
 4: if d<=21 then writeln('овен')   else writeln('телец');
 5: if d<=21 then writeln('телец')   else writeln('близницы');
 6: if d<=22 then writeln('близницы')   else writeln('рак');
 7: if d<=23 then writeln('рак')   else writeln('лев');
 8: if d<=24 then writeln('лев')   else writeln('дева');
 9: if d<=24 then writeln('дева')   else writeln('весы');
 10: if d<=24 then writeln('весы')   else writeln('скорпион');
 11: if d<=23 then writeln('скорпион')   else writeln('стрелец');
 12: if d<=22 then writeln('стрелец')   else writeln('козерок');
end;
end.

//без if вряд ли удаться обойтись(+ я не учитывал високосный год и кратный 100 и 400)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика