ответьте, очень надо.

На вход программы поступают 4 неотрицательных целых числа, не превышающие 1000, среди которых могут быть одинаковые. Нужно написать программу, которая выводит количество чисел, кратных 3, и максимальное из этих чисел. Если среди входных данных нет чисел, кратных трёх, программы должна вывести слово 'NO'. Для решения этой задачи ученик написал такую программу:

const n = 4;

var i, x: integer;

var maximum, count: integer;

begin

count := 0;

maximum := 999;

for i:=1 to n do begin

read( x );

if x mod 3 = 0 then begin

count := count + 1;

if x < maximum then

maximum := x;

end;

end;

if count > 0 then begin

writeln(count);

writeln(maximum);

end

else

writeln('NO');

end.

Последовательно выполните следующее.

1. Напишите, что выведет эта программа при вводе чисел 2 9 4 3.

2. Приведите пример такой последовательности, содержащей число, кратное 3, что, несмотря на ошибки, программа выдаст верный ответ.

3. Найдите все ошибки в этой программе (их может быть одна или несколько). Для каждой ошибки: выпишите строку, в которой сделана ошибка, и приведите правильный вариант

строки.

Обратите внимание, что требуется найти ошибки в имеющейся программе, а не написать свою, возможно, использующую другой алгоритм решения.

lexazykov20014 lexazykov20014    3   05.04.2020 18:30    18

Другие вопросы по теме Информатика