Составить программу на паскале.двумерный массив а[4; 4] заполнен случайными числами.посчитать сумму элементов каждой строки с процедуры.

ELIZA200425 ELIZA200425    1   12.09.2019 18:00    4

Ответы
abobov1234 abobov1234  07.10.2020 10:09
Const n=4;
var 
a:array[1..n,1..n] of integer;
i,j,s:integer;
procedure sum(k:integer; var s:integer);
var j:integer;
begin
s:=0;
for j:=1 to n do s:=s+a[k,j];
end;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 for j:=1 to n do
  begin
   a[i,j]:=random(100);
   write(a[i,j]:4);
  end;
  writeln;
 end;
for i:=1 to n do
 begin
 write(i,'-я строка: ');
 sum(i,s);
 writeln('s = ',s);
 end;
end.

Пример:
Исходный массив:
60 78 10 51
65 90 65 24
35 97 6 91
10 95 35 15
1-я строка: s = 199
2-я строка: s = 244
3-я строка: s = 229
4-я строка: s = 155
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика