От Задание из ЕГЭ по информатике. Написать программу, которая ищет в файле цифру, встречающуюся чаще всего.​

tel9057969295p0bj7i tel9057969295p0bj7i    2   02.02.2021 20:19    6

Ответы
marinamirom1 marinamirom1  04.03.2021 20:20

На Питоне:

path = 'F:/file.txt'

with open(path, 'r', encoding='utf-8') as f:

   data = f.read()

   f.close

a = [0 for i in range(10)]

for char in data:

   if char == '0': a[0]+=1

   elif char == '1': a[1]+=1

   elif char == '2': a[2]+=1

   elif char == '3': a[3]+=1

   elif char == '4': a[4]+=1

   elif char == '5': a[5]+=1

   elif char == '6': a[6]+=1

   elif char == '7': a[7]+=1

   elif char == '8': a[8]+=1

   elif char == '9': a[9]+=1

print(a)

digit = max(a)

if digit > 0:

   print(f'Самая часто встречающаяся цифра в файле {a.index(digit)}. Она встречается {digit} раз.')

else:

   print('В файле нет цифр.')

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика