tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Обработка одномерных массивов.
Обработка одномерных массивов. пользователь вводит слово. подсчитать количество букв d, c и k в этом слове.
CCybermann
2 13.07.2019 03:00
0
Ответы
joom3
03.10.2020 02:26
Var s: string;
ch: char;
i,d,c,k: integer;
begin
write('слово: '); readln(s);
i:=1; d:=0; c:=0; k:=0;
repeat
ch:=s[i];
case ch of
'd': d:=d+1;
'c': c:=c+1;
'k': k:=k+1;
end;
i:=i+1;
until i>length(s);
writeln('кол-во d = ',d,' кол-во c = ',c,' кол-во k = ',k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Joshler0canon
20.05.2019 19:00
Подсчитать произведение всех четных чисел от 1 до n (паскаль)...
ржакаmaker
22.03.2020 05:47
Для одновимірного числового масиву довжиною n розробіть програму з використанням рекурсивної функції обчислення добутку значень його елементів...
209439an
22.03.2020 05:50
в excel написать функцию для нахождения ежемесячного платежа....
Лидуня270516
22.03.2020 06:01
Паскаль, 8 класс1.Заполнить массив случ. числами в интервале [0,100] и отобрать в другой массив все числа. Используйте логическую функцию, которая определяет, является...
CrazyBublic02
26.03.2020 19:04
Что происходит в процессе форматирования текста, графического изображения и электронной таблицы?...
Sanya339
26.03.2020 19:05
Кумир. Напишите алгоритм (с иначе, если, пока) для выполнения. Точки—нужно закрасить....
ПолиночкаПоля1
26.03.2020 19:08
Дан двумерный массив А. Сформировать одномерный массив, в который войдут элементы из А, больше 4. Program primer_laba15; Var a : array [1..20,1..20] of integer; b : array...
ange4
26.03.2020 19:02
Навкдить алгоритм розв язання задач з використанням тенологий...
ahmetovalim
29.10.2020 09:04
Напишите пропущенное название информации...
marineshelunts
28.04.2019 19:05
Составьте программу ( размер 400 на 400) ❤️...
Популярные вопросы
Белоглазая самка скрещена с красноглазым самцом.определите цвет глаз...
2
Cтороны ac,ab,bc треугольника abc равны 3 корень из 2, корень 13, и...
3
Налог на доходы составляет 13% от заработанной платы. после удержания...
2
По карте часовых поясов определите время в астане, алматы, если в минске...
3
Долгий и трудный боксёрский поединок закончился нокаутом.судьи единогласно...
2
Найдите значение выражения: (-1/7+5/3)*131,25...
1
Решить квадратное уравнение: 4x^2-2x-6=0...
1
Решить , используя «цикл с параметром», «цикл с предусловием», «цикл...
2
На каком расстоянии от фонаря стоит человек ростом 1,6 м , если длина...
1
Человек рост которого равен 1,8м стоит на расстоянии 11 м от улчиного...
1
ch: char;
i,d,c,k: integer;
begin
write('слово: '); readln(s);
i:=1; d:=0; c:=0; k:=0;
repeat
ch:=s[i];
case ch of
'd': d:=d+1;
'c': c:=c+1;
'k': k:=k+1;
end;
i:=i+1;
until i>length(s);
writeln('кол-во d = ',d,' кол-во c = ',c,' кол-во k = ',k);
end.