Нужно, составьте программу на языке паскаль для нахождения радиуса описанной окружности вокруг треугольника, если известны стороны треугольника.

nariksalimov nariksalimov    2   28.08.2019 15:30    5

Ответы
vingers vingers  06.10.2020 00:49
Var
   a,b,c,p:real;
Begin
Write('a = ');ReadLn(a);
Write('b = ');ReadLn(b);
Write('c = ');ReadLn(c);
if (a<b+c)and(b<c+a)and(c<a+b) then
   Begin
   p:=(a+b+c)/2;
   WriteLn('R = ',a*b*c/Sqrt(p*(p-a)*(p-b)*(p-c)));
   End
else WriteLn('Треугольник не существует')
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика