Нужно составить программу в паскале.

вычислить s=1! +2! +3! +…+n! используя подпрограмму-функцию вычисления факториала.

Danielriisna13 Danielriisna13    3   30.06.2019 19:16    9

Ответы
FenomeN1703 FenomeN1703  02.10.2020 16:29

var

n,x,a,s:longint;

begin

read(n);

a:=1;

for x:=1 to n do

begin

a:=a*x;

s:=s+a;

end;

writeln(a);

end.

Программа будет работать для n<=12, если надо больше, то меняйте тип переменных a и s на int64 / uint64

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика