Нужно составить программу в Pascal ABC, которая будет разворачивать числа, например, 234=432​

sherilblo sherilblo    2   18.03.2020 16:39    4

Ответы
vanuaevstifeev vanuaevstifeev  27.08.2020 23:18

Var

n, m:integer;

a:byte;

Begin

readln(n);

m:=0;

while n>0 do begin

a:= n mod 10;

n:= n div 10

m:= m*10+a

end;

writeln(m) ;

End.

ПОКАЗАТЬ ОТВЕТЫ
20736 20736  27.08.2020 23:18

Для любого количества символом/цифр

begin

 var stroka := ReadString('Введите число/слово');

 for var i := Length(stroka) downto 1 do

   stroka += stroka[i];

 Delete(stroka, 1, length(stroka) div 2);

 Println('Реверс: ', stroka);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика