tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Нужно составить программу,которая
Нужно составить программу,которая формирует массив с 16 случайных целых чисел от -20 до 20 и: находит элементы с нулевыми значениями
elinakosogor30
2 15.08.2019 11:30
8
Ответы
mitaikooo
02.08.2020 16:51
Не понял смысл задачи.
Написал, вывод номера элементов равных 0.
ПОКАЗАТЬ ОТВЕТЫ
saaangelina
02.08.2020 16:51
#include <stdio.h>#include<stdlib.h>
int main(void){ int mas[16]; //массив со случайными числами int i; //счетчик
//заполнение массива случайными числами for(i=0; i<16; i++) mas[i] = -20+rand()%20; printf("ishodny massiv"); for(i=0;i<16;i++) printf("%d,",mas[i]); printf("\n");
printf("nomera elementov massiva ravnih nulu"); for(i=0;i<16;i++) if (mas[i]==0) printf("%d",i+1);
return 0;}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Dasha8999
09.07.2019 02:00
Можно ли букву и цифру назвать знаки ? почему?...
dankorolckov20
09.07.2019 02:00
Выберите из предложенного списка файлов только те, которые относятся к графическим (используются для хранения рисунков): my.doc, fami-ly.jpg, car.bmp, bell.mp3,...
школьник62728474щ3
30.04.2020 17:45
— У нас в классе 25 человек. И представь, каждый из них дружит ровно с 13 одноклассниками...— Не может этого быть, — сразу ответил Витя Иванов, победитель математической...
dana1969
30.04.2020 17:46
Определите значение переменнойпосле выполнения следующего фрагмента программы: S := 0;i := 5while i 0 do beginS := S + i;i := i - 1end;...
sking09
24.11.2020 06:26
ответить что тут правильно...
yanssen1976
24.11.2020 06:12
Клавиша «C»клавиша «P»клавиша «R»клавиша «S»выполнить...
M8ilen
24.11.2020 06:12
Выбери из предлагаемых кругов те, которые отвечают за тождество...
Anya183930303
24.11.2020 06:11
Показать Задание №1 Составьте сетевую модель. В первом ряду укажите имена друзей, во втором – их увлечения. Изобразите дугами связи: имя – увлечение. Задание №2...
Leprekon11
24.11.2020 05:51
Что представляет собой инструмент кривая Безье? 2. Какие режимы рисования кривых бывают? 3. Можно ли менять направление рисунка, созданного с кривых? 4. В каких...
86669
24.11.2020 05:16
Составить и записать алгоритм и программу для решения задачи: Обозначьте неизвестную любой буквой, составьте формулу. 1. За одно и то же время работы первый закройщик...
Популярные вопросы
2. Точки 0, P и T - соответственно середины ребер BC, SB и AB...
3
Образи повісті ЗА СЕСТРОЮ ....
2
Як провели день члени родини Грегора після його смерті? * 9...
3
Заполните таблицу очень надо...
2
2. Вставь пропущенные слова в предложения — 1. В конце 3 тыс....
1
Установите соответствие между названиями заболеваний (1-4) и...
2
1 Який звук долинав із майже затонулого корабля? Кому він на-...
2
Особливості повісті ЗА СЕСТРОЮ ....
1
Сравнить числа, найти их сумму и разность : 1) 13/20 и 7/20...
2
2. Обсудите с одноклассниками вопрос: Можно ли считать, что...
2
Написал, вывод номера элементов равных 0.
int main(void){ int mas[16]; //массив со случайными числами int i; //счетчик
//заполнение массива случайными числами for(i=0; i<16; i++) mas[i] = -20+rand()%20; printf("ishodny massiv"); for(i=0;i<16;i++) printf("%d,",mas[i]); printf("\n");
printf("nomera elementov massiva ravnih nulu"); for(i=0;i<16;i++) if (mas[i]==0) printf("%d",i+1);
return 0;}