Нужно подробное написание программы в pascalabc 1) с клавиатуры вводится число в интервале от 1 до 999. написать программу, которая определяет количество цифр во введенном числе. 2) написать программу, которая определяет, какая из двух точек расположена ближе к началу координат. координаты вводятся с экрана.

tmihailviktoroozvxn9 tmihailviktoroozvxn9    2   04.06.2019 20:40    4

Ответы
120505567890 120505567890  05.07.2020 16:52
program name;
var i,n,x,summa,count:integer;
nechet:boolean;
begin
Writeln('Vvedite n: ');
readln(n);//получаем n
summa:=0;
count:=0;
i:=1;
if(n mod 2 = 1) then nechet := true else nechet := false; //проверяем четное число или нет
while i<n do begin//пока число меньше n
if(nechet) then//если число нечентное
begin
summa:=summa+i*i*i;//прибавляем к сумме куб этого числа
end
else//если число четное
begin
summa:=summa+i*i;//прибавляем квадрат числа
end;
i:=i+1;//прибавляем число на 1
end;
writeln(' summa: ', summa);//выводим сумму
readln();
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика