tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Нужно написать программу вычисления
Нужно написать программу вычисления объёма усеченной пирамиды , в паскаль . v=h(sосн1+sосн2+корень(sосн1 sосн2))/3 . в паскаль
vapapsroyflmq
3 17.08.2019 07:30
5
Ответы
svetamax70
05.10.2020 00:16
Var
h,s1,s2,v:real;
begin
Write('Площадь нижнего основания пирамиды: '); Read(s1);
Write('Площадь верхнего основания пирамиды: '); Read(s2);
Write('Высота пирамиды: '); Read(h);
v:=h*(s1+s2+sqrt(s1*s2))/3;
Writeln('Объем пирамиды: ',v)
end.
Пример
Площадь нижнего основания пирамиды: 28
Площадь верхнего основания пирамиды: 17.5
Высота пирамиды: 9
Объем пирамиды: 202.907830863536
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
ibg478
23.09.2019 02:50
Нужно переделать эту программу на паскале для нахождения треугольника с самой большой площадью, образованным всеми вариантами точек uses crt,graphabc; var x,y: array[1..100]...
опалссио
18.05.2019 20:50
Внекотором текстовом редакторе используется только шрифт times new roman, для которого может быть установлен один из двух размеров. кроме того, имеется три кнопки,...
LOL2202
18.05.2019 20:50
Циклические алгоритмы: выполнить вычисления по формулам не и не изменяя их: r=2n+4n++14n k=m/n*m+1/n+1*m+2/n+*m+10/n+10...
arinkaapelsink
21.01.2020 17:09
Дан целочисленный массив из 30 элементов, все элементы которого – положительные числа, не превосходящие 100. опишите на языке или на одном из языков программирования...
спасибо84
19.05.2019 14:50
Вребусе зашифровано общее название многих программ , ? четверг (и нарисован трактор)...
Columbos
19.05.2019 14:50
ответьте на вопрос, выбрав вариант ответа. 1) рядом с названием какой группы нужно нажать на кнопку, чтобы появилось диалоговое окно, где можно разреженность текста...
yanashabanova1
17.05.2019 22:10
Raid-массив это 1) набор жестких дисков, подключенных особым образом 2) антивирусная программа 3) вид хакерской утилиты 4) база защищенных данных 5) брандмауэр...
Yanuska224
15.03.2020 00:57
Братья Богдан и Тарас перед началом учебного года купили 26 тетрадей в клеточку по 45 к., 16 тетрадей в линию по 60 к. и несколько ручек по 1 грн 20 к. За всю покупку...
nastenamolova0
15.03.2020 00:57
Решить квадратное уравнение 5х^-10х+17=0...
bogdanpavlovi
15.03.2020 00:57
Диалог на тему казахские писатели...
Популярные вопросы
5 сынып 5тапсырма 193 бет...
2
5.Хто такі Кирило та Мефодій? A) Автори Остромирового ЄвангеліяБ)...
2
В понедельник музей посетило 64 человека. Во вторник на 2 человека...
3
Визначте об єкт що є умовою...
1
Назвіть напрямки зовнішньої політики М. Хрущова? (5 прикладів)...
2
У скільки разів сума чисел 47 і 16 більша, ніж частка чисел 28...
1
Автомобіль долає деяку відстань за 8 год. Якщо він збільшить швидкість...
1
Составте простые предложения с данными глаголами употребив их в...
3
Напишите аргументированно эссе по тексту...
2
Listen and repeat the dialogue. What activity is Jim interested...
1
h,s1,s2,v:real;
begin
Write('Площадь нижнего основания пирамиды: '); Read(s1);
Write('Площадь верхнего основания пирамиды: '); Read(s2);
Write('Высота пирамиды: '); Read(h);
v:=h*(s1+s2+sqrt(s1*s2))/3;
Writeln('Объем пирамиды: ',v)
end.
Пример
Площадь нижнего основания пирамиды: 28
Площадь верхнего основания пирамиды: 17.5
Высота пирамиды: 9
Объем пирамиды: 202.907830863536