Нужно написать программу в паскале : с клавиатуры вводится число n. заполнить массив с клавиатуры n значениями и вывести их произведение.

vitalinabelova1 vitalinabelova1    1   03.06.2019 04:50    4

Ответы
ланя2 ланя2  03.07.2020 17:13
var
  a: array of byte; //Мы ведь не хотим выйти за пределы даже Int64?
  n, i: byte;          //Больше и не пригодится, массива из 255 значений хватит уж
  l: Int64 := 1;      //Произведение - большая цЫферка

begin
  readln(n);
  System.Array.Resize(a, n);
  for i := 0 to (n - 1) do
  begin
    write('a[', i, '] = ');
    readln(a[i]);
    l *= a[i];
  end;
  writeln(l);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика