Нужно написать программу в "паскале" для перевода из любых систем исчисления в десятичную.

svetar2014 svetar2014    1   18.07.2019 03:40    2

Ответы
Lider4k Lider4k  21.09.2020 21:57
Var
  n, k, i: integer;
  s: string;
begin
  write('Введите число: ');
  read(s);
  write('Введите исходную систему счисления: ');
  read(k);
  for i := 1 to length(s) do
    n := n * k + ord(s[i]) - 48;
  write(s, '(2) = ', n, '(10)');
end.

Пример работы программы:
Введите число: 101000111000111
Введите исходную систему счисления: 2
101000111000111(2) = 20935(10)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика