Нужно написать программу в паскале дан механизм,состоящий из двух шестеренок. у одной шестеренки n зубцов,у другой k. требуется найти какое минимальное число поворотов на один зубчик требуется сделать,чтобы шестеренки вернулись в исходное состояние.
Program task; var i,n,k:longint; begin writeln('n?'); readln(n); writeln('k?'); readln(k); for i:=1 to n*k do begin if ((i mod n = 0) and (i mod k = 0)) then begin writeln(i); break; end; end; readln; end.
var i,n,k:longint;
begin
writeln('n?');
readln(n);
writeln('k?');
readln(k);
for i:=1 to n*k do begin
if ((i mod n = 0) and (i mod k = 0)) then begin
writeln(i);
break;
end;
end;
readln;
end.