Нужно написать программу в pascal'е. описано так. требуется выделить из предложения четвертое слово (слова разделены пробелом).

Suri31 Suri31    1   11.09.2019 13:10    3

Ответы
Var
  s: string;
  i: integer;
  qp: integer;
  word: string;
begin
writeln('Введите предложение разделяя слова пробелами');
readln(s);
qp:=0;
word:='';
for i:=1 to length(s) do begin
  if s[i]=' ' then
    qp:=qp+1
  else begin
     if qp=3 then word:=word+s[i];
  end;
  if qp=4 then
     break;
end;
if word='' then
  writeln('четвёртое слово не присутствует')
else
  writeln('искомое слово - ', word);

end.

{Пример}
На pascal написана соответствующая программа 
искомое слово - соответствующая
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика