Нужно написать программу скорей всего мне кажется в паскале 1. writel(' вести стоимость перчатки наприм') read (x) 2 стоимость сумки- наприм. 3.стоимость ремня- наприм. 4.если общая сумма больше 800р, то вывести сумму с учетом 10% скидки 5.если сумма меньше 800р, то вывести сумму нужно, !

2004пупик4 2004пупик4    2   18.05.2019 23:30    1

Ответы
irinacheprasova irinacheprasova  12.06.2020 05:08

program test;
var x: integer;
var y: integer;
var z: integer;
var sum: real;
begin
readln(x);
readln(y);
readln(z);
sum:=x+y+z;
if sum>=800 then sum:=sum -sum/10;

writeln(Trunc(sum));
end.

ПОКАЗАТЬ ОТВЕТЫ
volegorex volegorex  12.06.2020 05:08

var x,a,b,sum:integer;

begin

writeln ('Введите стоимость перчатки');

readln (x);

writeln ('Введите стоимость сумки');

readln (a);

writeln ('Введите стоимость ремня');

readln (b);

 

sum:=a+b+x;

 

if (sum>800) then  writeln (sum-(sum/100*10));

if (sum<800) then writeln (sum);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика