Нужно написать программу на языке паскаль условие такое: вводится 15 чисел определить каких чисел кратных трём больше положительных или отрицательных

serega5152 serega5152    1   13.08.2019 08:20    8

Ответы
elv1n elv1n  04.10.2020 15:29
Var a,p,n,i:integer;
begin
 p := 0;
 n := 0;
 for i := 1 to 15 do
  begin
  read(a);
  if a mod 3 = 0 then
    if a > 0 then p := p + 1
    else
    if a < 0 then n := n + 1
  end;
  if p > n then writeln('Положительных') else
  if p < n then writeln('Отрицательных') else
    writeln('Одинаково')
end.

{вариант "как-то посложнее"}

var a,i,s:integer;
begin
 s := 0;
 for i := 1 to 15 do
  begin
  read(a);
  s := s + ord(a mod 3 = 0) * (ord(a > 0) - ord(a < 0))
  end;
 if s > 0 then writeln('Положительных') else
 if s < 0 then writeln('Отрицательных') else
 writeln('Одинаково')
end.   
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика