Нужно написать программу на паскале: в матрице размера m×n положительные элементы заменить единицей. создание и вывод матриц оформить в виде процедур.

kulakovakatyus kulakovakatyus    3   26.09.2019 20:30    4

Ответы
Юлия0753 Юлия0753  16.08.2020 22:48
PascalABC.NET 3.4.0, сборка 1675 от 12.06.2018
Внимание! Если программа не работает, обновите версию!

procedure MatrixCreate(m,n:integer; var A:array[,] of integer);
begin
  A:=MatrRandom(m,n,-50,50);
end;

procedure MatrixOutput(A:array[,] of integer);
begin
  A.Println(4)
end;

begin
  var (m,n):=ReadInteger2('Количество строк и столбцов в матрице:');
  var a:array[,] of integer;
  MatrixCreate(m,n,a);
  Writeln('*** Исходная матрица ***');
  MatrixOutput(a);
  a.Transform(t->t>0?1:t);
  Writeln('*** Полученная матрица ***');
  MatrixOutput(a);
end.

Нужно написать программу на паскале: в матрице размера m×n положительные элементы заменить единицей.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика