решить 2 задачи через питон Напишите программу, которая в последовательности натуральных чисел определяет сумму
всех чисел, кратных 6 и оканчивающихся на 4. Программа получает на вход натуральные
числа, количество введённых чисел неизвестно, последовательность чисел заканчивается
числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел
не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно
число: сумму всех чисел, кратных 6 и оканчивающихся на 4

Напишите программу, которая в последовательности целых чисел определяет их сумму и
количество чётных чисел, кратных 5. Программа получает на вход целые числа, количество
введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак
окончания ввода, не входит в последовательность). Количество чисел не превышает 1000.
Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа:
сумму последовательности и количество чётных чисел, кратных 5.

женя1362 женя1362    1   07.12.2020 22:27    5

Ответы
vda200311 vda200311  06.01.2021 22:34

1)

while True:

   num = int(input())

   NumS = str(num)

   if num == 0:

       break

   if num % 6 == 0 and NumS[len(NumS) - 1] == "4":

       summ += num

print(summ)

2)

while True:

   num = int(input())

   if num == 0:

       break

   summ += num

   if num % 2 == 0 and num % 5 == 0:

       count += 1

print(summ, count)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика