Нужно написать программу на паскале обязательно используя цикл for. программа вычисляет среднее арифметическое положительных элементов ряда чисел. каждый элемент ряда вычисляется по формуле: (12*k-21)/3, где k--номер элемента в ряду. всего элементов--необходимо спросить.

rudembatalov rudembatalov    3   25.08.2019 22:30    2

Ответы
Rzaevat Rzaevat  26.08.2020 09:56
Var K,n:integer;
S:real;
Begin
n:=0;
Write('K = ');ReadLn(K);
For K:= 1 to K do
    Begin
    Write((12*K-21)/3,' ');
    if (12*K-21)/3 > 0 then
       Begin
       S:=S+(12*K-21)/3;
       n:=n+1
       End;
    End;
WriteLn;
Write('Sr = ',S/n)
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика