Нужно написать программу на pascalabc. вводится n чисел, найти максимальное двузначное среди них.

CrazyBublic02 CrazyBublic02    2   16.07.2019 18:20    3

Ответы
йцукен56 йцукен56  21.09.2020 12:23
Var
  n,max,i,a : longint;
begin
  readln(n); {количество чисел}
  max:=0; {чтобы вывести 0 если нет двухзначных}
  for i:=1 to n do
    begin
      readln(a); {хранить массив не надо т.к. он нигде не требуется}
      if (a>9) and (a<100) and (a>max)
        then max:=a;
    end;
  if max>0
    then writeln(max)
    else writeln('нет двухзначных чисел')
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика