Нужно написать программу на delphi: вводится кол-во переменных с клавиатуры на выходе 2 числа: сумма чисел, произведение квадратов. то есть "введите кол-во переменных" 2 3 3 сумма = 6 произведение квадратов = 81

Бyлaт Бyлaт    2   31.07.2019 15:20    4

Ответы
Kurban9595 Kurban9595  28.09.2020 17:49
Консольное приложение:
program Pr1; 

{$APPTYPE CONSOLE} 

var 
  N, a, i, s: integer; 
  p: double; 

begin 
  WriteLn('Введите кол-во переменных '); 
  ReadLn(N); 

  s:=0;
  p:=1;
  for i:=1 to N do begin 
    ReadLn(a); 
    s:=s+a;
    p:=p*a*a;
  end; 
  WriteLn( 'Сумма = ',s);
  WriteLn('Произведение квадратов = ',p); 
  ReadLn; 
end.

Пример:
Введите кол-во переменных 
5
4
6
2
7
3
Сумма = 22
Произведение квадратов = 1016064
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика