На паскале скринн всего экрана Задача А. С клавиатуры вводится натуральное число. Напишите программу, которая выводит “ДА”, если число четное, иначе - “НЕТ”.
Задача Б. В компьютер вводятся два числа. Если первое больше второго, то вычислить их сумму, иначе - произведение. После этого компьютер должен напечатать результат

2006лера 2006лера    2   13.11.2020 22:18    11

Ответы
кошка3310 кошка3310  13.12.2020 22:19

А)

program num;

var

 number: integer;

begin

 read(number);

 if (number mod 2 = 0) then

   write('ДА')

 else

   write('НЕТ');

end.

Б)

program b;

var

 first, second: integer;

begin

 read(first, second);

 if (first > second) then

   write(first + second)

 else

   write(first * second);

end.

Объяснение:

А)

program num; // Название программы

var

 number: integer; // Целочисленная переменная, хранящая вводимое с клавиатуры число

begin // Начало программы

 read(number); // Считываем число с клавиатуры

 if (number mod 2 = 0) then // Если остаток от деления значения переменной number на 2 = 0, тогда

   write('ДА') // Выводим "Да"

 else // Иначе

   write('НЕТ'); // Выводим "Нет"

end. // Конец  программы

Б)

program b; // Название программы

var

 first, second: integer; // Целочисленные переменные, хранящие вводимые с клавиатуры числа

begin // Начало программы

 read(first, second); // Считываем числа с клавиатуры

 if (first > second) then // Если первое число > второго числа, тогда

   write(first + second) // Выводим сумму этих чисел

 else // Иначе

   write(first * second); // Выводим произведение этих чисел

end. // Конец  программы

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика