Нужно ! написать программу, которая вычисляет среднюю температуру воздуха за 10 дней, выводит на экран маx и миn значение. (данные вводятся с клавиатуры).

nikitarin0 nikitarin0    3   12.09.2019 13:20    2

Ответы
enzhedob enzhedob  07.10.2020 09:43
Const Sz = 100; // Размер массива

var
a: array [1..Sz] of integer;
N: integer; // Количество элементов в массиве
i,k: integer;
min,max: real;
begin
k:=0;
N:= 10;
write('Введите элементы массива: ');
for i:=1 to N do begin
read(a[i]);
k:=k+a[i];
end;
write('Вывод элементов массива: ');
for i:=1 to N do
write(a[i],' ');
min := a[1];
for i:=2 to N do
if a[i]<min then
begin
min := a[i];
end;
max := a[1];
for i:=2 to N do
if a[i]>max then
begin
max := a[i];
end;
writeln('max=',max,' ','min=', min,' ','Средная температура=',k/N3)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика