Напишите программу для вычисления значения выражения, используя функцию.


Напишите программу для вычисления значения выражения, используя функцию.

лилия371 лилия371    3   03.12.2020 13:47    5

Ответы
lulchik08 lulchik08  02.01.2021 13:47

import math

#округление чисел

def float_(num, places = 0, direction = math.floor):

   return direction(num * (10**places)) / float(10**places)

#твоя формула

def formula(a,n):

   return (a ** n) / (a**(n-1) + a**(n-2))

a = int(input(f"Введите a\n"))  # Ввод

n = int(input(f"Введите n\n"))  # Ввод n

K = float_(formula(a,n), 2)  # к K присваивается функция formula

print(f"K = {K}") # Вывод K

Объяснение:

Написано на python(питоне) 3.7+


Напишите программу для вычисления значения выражения, используя функцию.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика