Нужно написать программу, где вызывается функция, выводящее первое простое число в указанном диапазоне. Нужно ввести начало и конец диапазона. Если в указанном диапазоне нет ни одного простого числа, программа должнв выдать сообщение There is no prime На языке с++

оскар4444 оскар4444    3   21.05.2021 15:30    1

Ответы
1izzka000 1izzka000  20.06.2021 15:32

#include <iostream>

#include <cmath>

using namespace std;

bool is_prime_num(int x) {

   for(long long i=2 ; i <= sqrt(x); i++)

 if( x % i == 0)

  return false;

return true;

}

int main()

{

   int arr[10000];

   int n;

   cin >> n; // вводим кол-во элементов массива

   for (int i = 0; i < n; i++)  {

       cin >> arr[i]; // вводим элементы массива n раз

   }

   int a,b;

   cin >> a >> b; // вводим границы диапазона

   int result = 0;

   

   for (int i = a; a < b; i++) {

       if (is_prime_num(arr[i])) {

           result = arr[i];

           break;

       }      

   }

   if ( result == 0) cout << "There is no prime";

   else cout << result;

   return 0;

}

Объяснение:

 Как - то так, если что непонятно - спрашивай

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика