Нужно написать программу для авс паскаль. программа должна переводить обыкновенные числа в двоичную систему счисления. заранее большое ! 87

нррроь нррроь    3   17.08.2019 20:40    4

Ответы
SUPERMARY007 SUPERMARY007  05.10.2020 01:30
Var n,m:integer;
s:string;
begin
write('n = ');
readln(n);
m:=n;
s:='';
while m>0 do
 begin
 if m mod 2=0
  then s:='0'+s else s:='1'+s;
 m:=m div 2;
 end;
writeln(s);
end.

Пример:
n = 115
1110011
ПОКАЗАТЬ ОТВЕТЫ
volodjpanchuk19 volodjpanchuk19  05.10.2020 01:30
Var
  a: integer;

function p(x: integer): string;
var
  s: string;
begin
  s := '';
  while x > 0 do
  begin
    s := chr(ord('0') + x mod 2) + s;
    x := x div 2;
  end;
  p := s;
end;

begin
  readln(a);
  writeln(p(a));
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика