Нужно написать 2 программы желательно в pascal abc программа 2. пользователь вводит две целые переменные a, b. написать программу для выполнения следующих операций: 1 вычислить результат целочисленного деления a на b; 2 вычислить результат деления a на b; 3 вычислить результат деления a на b, вывести его дробную часть; 4 вычислить результат деления a на b, вывести его целую часть; 5 вычислить результат деления a на b, округлить его. программа 3. предложите пользователю ввести трехзначное число, сохраните это число в одну целочисленную переменную, переверните цифры в этом числе.

polo73oye61z polo73oye61z    1   02.04.2019 08:00    6

Ответы
feeedf feeedf  28.05.2020 10:39

1 задание.

uses crt;
var
a, b : real;
begin
readln (a, b);
writeln (a/b);
writeln (frac(a/b));
writeln (int(a/b));
writeln (round(a/b));
readkey;
end.

 

2 задание.

uses crt;
var
a: integer;
st, st1, st2, st3: string;
begin
readln (a);
str (a, st);
st1:=st[3];
st2:= st[2];
st3:= st[1];
st:= st1+st2+st3;
writeln (st);
readkey;
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика