Нужна ! с операторов div и mod написать программу в паскале. на вход- трехзначное число. на выход- вывести на экран количество сотен, десятков и единиц в этом числе.

svetusik214 svetusik214    2   03.10.2019 13:10    2

Ответы
Ilusich Ilusich  09.10.2020 14:15

Program N1;

var a,c1,c2,c3: integer;

begin

 writeln('Введите число');

 read(a);

 c1:=a mod 10;

 c2:=(a div 10) mod 10;

 c3:=(a div 100) mod 10;

 writeln('Кол-во сотен = ',c3);

 writeln('Кол-во десятков = ',c2);

 writeln('Кол-во единиц = ',c1);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика