Нужна ) написать программу в python, которая запрашивает у пользователя имя файла со стихотворением и распечатывает строку с наибольшим количеством согласных букв.

sivtsevavera2005 sivtsevavera2005    2   02.09.2019 18:00    3

Ответы
zepoo zepoo  06.10.2020 12:52
Python 3.6.1:

print('Введите путь к файлу: ')
f = open(input(),'r')
B = 'бвгджзклмнпрстфхцчшщ'
Max = 0
for S in f:
    k = 0
    for C in S.lower():
        if C in B:
            k+=1
    if k > Max:
        Max = k
        MaxS = S
print(MaxS)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика